Skip to end of metadata
Go to start of metadata

Problem:


Wir nutzen für unsere Collaboration Hub-Nutzer die direkte Einbettung von Prozessen via IFrame in Sharepoint Online.
Seit kurzem wird uns aber leider keiner dieser Prozesse mehr angezeigt. Stattdessen erhalten wir die Fehlermeldung: 

"Sie haben keinen Zugriff auf diese Ressource, sie wurde gelöscht oder sie befindet sich außerhalb Ihres Arbeitsbereiches.
Gehen Sie zum Einstiegsdiagramm oder wenden Sie sich an Ihren Arbeitsbereichsleiter."

Navigieren wir jedoch wie beschrieben zum Einstiegsdiagramm und klicken uns anschließend zu dem betroffenen Prozess durch das Collaboration Hub, wird der Prozess ohne Probleme dargestellt.
Wie lässt sich das erklären?



Solution:


Das Problem lässt sich auf den Umgang von Links aufseiten von Sharepoint eingrenzen.
Nutzen Sie noch nicht die Velocity Edition mit dem neuen Collaboration Hub, so sieht der Aufbau der URL für die IFrame-Einbettung eines Prozesses wie folgt aus:

https://editor.signavio.com/p/hub#/model/"model ID"

Der Fehler tritt hier bei dem Encoding des Hashtags "#" innerhalb der URL, in Sharepoint auf.
Beim Versuch den Link innerhalb des IFrames aufzurufen, wird der Link wie folgt durch die Sharepoint Anwendung verändert und kann nicht mehr aufgerufen werden:

https://editor.signavio.com/p/%2Fmodel%"model ID"

Eine Lösung seitens Signavio kann in diesem Fall nicht angeboten werden, da dieses Problem innerhalb der Sharepoint (Microsoft)-Anwendung auftritt.

Als möglichen Workaround bieten wir an, auf die Velocity Edition mit dem neuen Collaboration Hub zu wechseln
Dort wird innerhalb der URL kein Hashtag mehr verwendet.