Skip to end of metadata
Go to start of metadata

Problem:


Auf unserem Testsystem bin ich nicht mehr in der Lage, Modelle im Process Explorer über "Neu" -> <Modelltyp>(Bspw. BPMN2.0) anzulegen. Ich erhalte einen Fehler, dass ich nicht die notwendigen Berechtigungen habe. Ich rufe das Testsystem über die Adresse http://test.company.com/ auf. Ich melde mich direkt im Explorer vom Signavio Process Manager an.


Folgendes haben wir bereits versucht:
1. Wir haben meinen Benutzer bereits gelöscht und neu angelegt
2. Ich habe meinen Cache geleert.

Unser Testsystem ist wie folgt konfiguriert.


configuration.xml
 <server>http://testsystem.company.net</server>


Solution:


Dieser Fehler tritt auf, da hier mit einer anderen Base-URL gearbeitet wird. Im der Serverkonfiguration ist als Standardadresse "testsystem.company.net" definiert. Wenn Sie sich aber standardmäßig mit "test.company.net" anmelden gilt der Token, sowie das Sitzung-Cookie für die eingegebene Adresse "test.company.net". Wenn Sie nun eine Aktion im Explorer ausführen und einen neuen Prozess erstellen, werden Sie durch die konfigurierte Base-URL auf "testsystem.company.net" umgeleitet. Dadurch verändern sich essentielle Teile der Base-URL und passen somit nicht mehr zum vereinbarten Sitzungs-Cookie/Token. Das System lehnt die Benutzereingabe ab, da es sich hierbei für das System, um ein komplett andere Plattform handelt.

Sie können dies korrigieren in dem Sie die Base-URL entsprechend in der "configuration.xml" anpassen oder die dort hinterlegte URL verwenden.